macOS Catalina

Attention all customers! We can confirm that our products are working in MainStage 3 running on macOS Catalina 10.15+.

Please note, we only recommend updating to Catalina when you can confirm that ALL of your other software and hardware is compatible. When upgrading, please make a Time Machine backup prior, just in case something doesn't work as expected after you upgrade.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us